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User's Guide

MetaTrader 4 Client Terminal is the client part of online trading platform MetaTrader 4. The program has 

a simple and user friendly interface that allows traders to monitor their transactions and their account as 

well as perform technical analysis and develop trading strategies of their own. It is the best solution for 

trading on Forex, CFD and Futures markets.

Client terminal MetaTrader 4 key features:

• working with securities of Forex, Futures and CFD markets; 

• various execution technologies: Instant Execution, Request Execution, Market Execution; 

• confidentiality of all trading operations; 

• unlimited charts quantity; 

• support of various timeframes (from minutes up to months); 

• large number of technical indicators and line studies; 

• experts, Custom Indicators and Scripts; 

• multiLanguage program interface including ARABIC 

• realtime data export via DDE protocol; 

• signals of system and trading actions; 

• getting on-line news from financial markets; 

• internal e-mail system; 

• printing charts and completed trading transactions statemets

M E T A T R A D E R  4  U S E R  G U I D E

• MetaTrader 4 overview   
• Real-time quotes in the "Market Watch" window   
• Charts   
• Open/close a position   
• Stop Loss and Take Profit orders   
• Trailing Stop   
• Pending Orders  

MetaTrader 4 overview
MetaTrader 4 is the latest and most effective dealing software for 

Internet trading on Forex and CFDs developed by MetaQuotes 

Software Corp.
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K E Y  F E A T U R E S  O F  M E T A T R A D E R  4

1.Internet trading on Forex and CFDs; 

2.Various execution technologies: Instant Execution and Request Execution; 

3.Complete technical analysis package: wide range of in-built indicators and charting 
tools, the ability to create various custom indicators, different time periods (from 
minutes to months);
In-built program language MetaQuotes Language 4 to write custom trading strategies 
(Expert Advisors) and the possibility to test them on the historical data; 

4.Multilingual platform interface (English, German, French, Russian, Arabic, 
Spanish, Farsi, Japanese, Chinese Simplified, Polish, Turkish, Korean, Indonesian, 
Bulgarian etc.); 

5.Real time data export to Metastock and Omega Prosuite 2000; 

6.Internal mail; 

7.History database management and import/export facility; 

8.MetaTrader Mobile: MetaTrader 4 Mobile for PDA; 

9.In-built help guides for MetaTrader 4 and MetaQuotes Language 4. 

MetaTrader 4 can be downloaded free of charge. In order to gain experience and better 

knowledge of the trading platform you can open a demo account. For further questions feel 

free to ask our Helpdesk / Customer Support.

Attention: MetaTrader 4 does not operate under Windows 95. Minimum required screen 

resolution is 1024x768.

Metatrader 4 Server IP-addresses are specified in the FAQ section.

• MetaTrader 4 User Guid  e  
• Download Metatrader 4   
• MetaTrader 4 Mobile   

E X P E R T  A D V I S O R S  I N  M E T A T R A D E R  4

The Expert Advisors technology is a new method of trading which frees you from daily 

manual routines. Expert Advisor written in MetaQuotes Language 4 (MQL 4) automatically 

analyses current market situations, opens/closes positions and places/modifies/deletes orders.

With the help of Expert Advisors you can:
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1.avoid everyday manual routines by automating the process of trading and 
monitoring orders; 

2.be more scientific and rational in your decision making process; 

3.keep track of the current market situations.
Implement your trading strategy in Expert Advisor by using MetaQuotes Language 4 
and your MetaTrader 4 will manage your trading account without the need to be 
present 24 hours a day, 5 days a week. 

MetaQuotes Language 4 is used to write:

• Expert Advisors   mechanical trading systems which can be used either for trading 
alerts or for trading and monitoring orders (automatically without your presence); 

• Custom Indicators   indicators created by you or other users of MetaTrader 4 client 
terminal in addition to the in-built technical indicators, integrated into MetaTrader 4; 

• Scripts   modules which execute repeated actions; 
• Libraries - frequently used user's programs. 

MetaQuotes Language 4 allows you to call functions from the external dll-libraries and get 

access to the computer file system. This makes it possible to implement trading strategies of 

ANY complexity.

The new Expert Advisors testing technology uses historic data. Using this data you can test 

the effectiveness of your trading strategies, usually within a few minutes.

MetaQuotes Language 4 is very easy to learn and understand even for those who have no or 

limited experience as computer programmers.

Learn more about MetaQuotes Language 4

M E T A T R A D E R  4  M A I N  S C R E E N

www.meta-trader.co.uk  we programm your Strategie



www.meta-trader.co.uk

• Main menu (access to the program menu and settings); 

• Toolbars (quick access to the program features and settings); 

• "Market Watch" window (real-time quotes for the specified instruments); 

• "Navigator" window (quick access to all your accounts, indicators, expert advisors); 

• "Chart" window; 

• "Terminal" window (quick access to the trading and account history, list of open positions and 
placed orders, client terminal log-file and internal mailbox). 

Real-time quotes
The "Market Watch" window can be activated by pressing the Ctrl+M key combination, or by 

using the View -> Market Watch menu sequence or by clicking the button from the 

"Standard" toolbar:
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Standard toolbar

Right click the mouse button on the "Market Watch" window to produce the context menu:

Market Watch window

• New Order – enables the window to open/close a position or to place a new pending 
order; 

• Chart Window – enables the chart of a currency pair or CFD; 
• Tick Chart – shows the tick chart for the selected instrument; 
• Hide – deletes the specified symbol from the list in the "Market Watch" window; 
• Hide All – deletes all symbols from the list in the "Market Watch" window which are 

not used (if you have open positions or charts, its symbols will not be deleted); 
• Show All – displays all available symbols in the "Market Watch" window; 
• Symbols – enables the window where you can hide/show the selected instruments; 
• Sets – saves/adjusts/deletes the custom settings for the "Market Watch" window; 
• High/Low – shows/hides columns with the highest and lowest prices for each 

instrument; 
• Time – displays a column with the arrival time of the latest quote for each instrument; 
• Grid - hides/unhides gridlines in the "Market Watch" window; 
• Popup Prices – opens the popup window which contains real time quotes for your 

selected instruments.
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Open/close a position
In order to enable the "Order" window:

• right click on the "Market Watch" window or on the "Trade" tab of the "Terminal" 
window and select New order from the context menu; or 

• press the F9 button; or 
• use the Tools -> New order menu sequence; or 
• right click on the chart window and select Trading -> New Order from the context 

menu; or 
• double click on the currency pair in the "Market Watch" window.

The "Order" window:

Order window (Instant Execution)

In MetaTrader 4 there are two ways of making deals: "Instant Execution" and "Request 

Execution".

Instant Execution means that you do not have to request quotes, as you see real-time dealable 

prices in the "Order" window and in the "Market Watch" window. Once you have decided to 

buy or sell at the current price press the Buy or Sell buttons to open a long or short position. 

For the instruments which are traded in the Instant Execution mode all quotes which are in the 

"Market Watch" window are executable, not indicative.
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For the instruments traded in the Request Execution mode all quotes in the "Market Watch" 

window are indicative and the Buy and Sell buttons are inactive. In order to make a deal you 

should request the quote from Alpari (UK) by pressing the Request button:

Order window (Request Execution)

Once you see the quote it remains dealable for several seconds:
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The quote is valid for making a deal within several seconds

Once the Buy or Sell button is pressed and Alpari (UK) confirms the deal, consider your new 

long or short position open:

Deal execution confirmation

The position is now listed in the "Trade" tab of the "Terminal" window.

"Instant Execution" technology has many advantages over "Request Execution". Instant 

Execution only takes a few seconds to deal compared to the "Request Execution" which can 

take up to 30-40 seconds (on the demo accounts all operations are made within few seconds, 

as demo accounts are quoted automatically, whilst live accounts are quoted manually). 

Furthermore in case of Request Execution, all quotes in the "Market Watch" window are 

indicative, so they may differ from those offered by the Company for making a deal.

Before you make a deal you can change its details in the "Order" window:

• Symbol - a currency pair or CFD you choose to make a deal; 

• Volume - number of lots; 

• Stop Loss - the level of Stop Loss order; 

• Take Profit - the level of Take Profit order; 

• Comment - any notes.
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In order to close a position, highlight it in the "Trade" tab of the "Terminal" window and right 

click to obtain the context menu:

The context menu of the Trade tab of the Terminal window

then select Close order. Left double clicking on the open position in the "Trade" tab of the 

"Terminal" window will have the same result. The “Order #__ ...” window appears:

Close the position (Instant Execution)

For instruments which are traded in the "Request Execution" mode, you have to request a 

quote before closing a position:
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Close the position (Request Execution)

Once you press the Request button Alpari (UK) gives you the quote and the "Close #position 

number …" button becomes available:

Close the position (Request Execution) - step 2
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If a currency pair or a CFD is traded in the" Instant Execution" mode there is no need to 

request a quote. This is why once the “Order #__ ...” window appears the "Close #position 

number …" button becomes active.

If the market is stable then execution is usually made at the quote shown by Alpari (UK). 

Sometimes, however, the market can be very volatile and the quote offered several seconds 

ago may become invalid (even before those several seconds, which are given to you for the 

decision-making process, run out). In this case the quote is revoked and the "Requote" 

window with a new quote appears.

Stop Loss / Take Profit
Stop Loss - an order to close a previously opened position at a 

price less profitable for the Customer than the price at the time of 

placing the order.

Take Profit – an order to close a previously opened position at a 

price more profitable for the Customer than the price at the time 

of placing the order.

If you place these types of orders you do not have to sit in front of your computer to wait for 

the outcome. Take Profit and Stop Loss orders will be executed automatically as soon as the 

price reaches order level (see below). You can place Stop Loss and Take Profit at the time of 

making a deal filling in the "Stop Loss" and "Take Profit" fields in the "Order" window:
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How to place Stop Loss and Take Profit orders in the Order window

Afterwards in order to modify Stop Loss and Take Profit levels use the context menu:

The context menu of the Trade tab of the Terminal window

Right click on the open position or on the pending order in the "Trade" tab of the "Terminal" 

window then select Modify or delete order. The "Modify order" window enables:
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The Modify Order window

Fill in the "Stop Loss" and "Take profit" fields. By pressing the red button (in our example 

"1.2121") you can copy this level into the "Stop Loss" field. By pressing the blue button (in 

our example "1.2096") you can copy this level in the "Take profit" field. The value in the 

"Level" field defines the difference between the order level and the current price. Once you 

fill in the "Stop Loss" or/and "Take profit" fields press the "Modify #position number ..." 

button.

The limits for the minimum range between the order and the current price are defined in the 

Contracts Specifications.

In order to delete Stop Loss or Take profit orders specify its level as equal to zero.

Stop Loss and Take profit orders are executed in the following cases:

• the Take Profit order on an open Buy position is executed if the Bid price in the quotes 
flow becomes equal or higher than the order level; 

• the Stop Loss order on an open Buy position is executed if the Bid price in the quotes 
flow becomes equal or lower than the order level; 

• the Take Profit order on an open Sell position is executed if the Ask price in the 
quotes flow becomes equal or lower than the order level; 

• the Stop Loss order on an open Sell position is executed if the Ask price in the quotes 
flow becomes equal or higher than the order level.
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The order will be executed if at least one quote in the quotes flow reaches the order level. 

Note, that in MetaTrader 4 charts are created using Bid prices, so:

• minimum Ask price is equal to the minimum bar price (Low) plus spread; 
• maximum Ask price is equal to the maximum bar price (High) plus spread; 
• minimum Bid price is equal to the minimum bar price(Low); 
• maximum Bid price is equal to the maximum bar price (High).

Important: If under abnormal market conditions the order level falls within the price gap, 

Alpari (UK) has the right to execute the order at the Bid or Ask price (depending on order 

type) of the first obtainable after the gap quote.

Trailing Stop
Trailing Stop is an algorithm to manage Stop Loss orders.

Once a trailing stop has been placed (for example, trailing stop's value is 15 pips) the 

following occurs:

1.No Stop Loss order will be placed until the open position is in a profit of at least 15 pips. 
MetaTrader 4 then sends an instruction to place the Stop Loss order 15 pips higher or 
lower than the current price. 

2.Subsequently, each time the difference between the current price and the order 
level exceeds 15 pips, MetaTrader 4 sends the instruction to modify the Stop Loss 
order to a level 15 pips higher or lower than the current price. As a result, the Stop 
Loss order becomes closer to the current price.
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How to specify Trailing Stop level

Important: It is very important to note that no Stop Loss order will be placed until the market 

moves in your favour as mentioned above. Therefore until this has happened, to limit losses, a 

separate Stop Loss would need to be placed manually.

In order to place a trailing stop highlight the open position in the "Trade" tab of the 

"Terminal" window and right click to open the context menu.

Pending Orders
Pending order is an instruction to open a position when the current 

price reaches the order level.

There are four types of pending orders:

1.Buy Stop - an order to open a Buy position at a price higher than the price at the 
moment of placing the order; 

2.Sell Stop - an order to open a Sell position at a price lower than the price at the 
moment of placing the order; 

3.Buy Limit - an order to open a Buy position at a lower price than the price at the 
moment of placing the order; 

4.Sell Limit - an order to open a Sell position at a price higher than the price at the 
moment of placing the order.
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Types of pending orders

In order to place a pending order, open the "Order" window by any way described below:

• right click on the "Market Watch" window or on the "Trade" tab of the "Terminal" 
window and select New order from the context menu; or 

• press the F9 button; or 
• use the Tools -> New order menu sequence; or 
• right click on the chart window and select Trading -> New Order from the context 

menu; or 
• double click on the currency pair in the "Market Watch" window.

Then choose the Pending order item from the drop down list:
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How to place pending order

The following options may be changed in this window as well:

• Symbol - currency pair or CFD; 

• Volume - transaction size in lots; 

• Stop Loss - Stop Loss order level which will be activated once the pending order has been 
executed; 

• Take Profit - Take Profit order level which will be activated once the pending order has been 
executed; 

• Comment - your comments for the pending order; 

• Type - the type of pending order: Buy Stop, Buy Limit, Sell Stop, Sell Limit; 

• At price - pending order level; 

• Expiry - if the box has not been checked the order is valid up to the time when you cancel it 
or when it is executed. If the box is checked the order is valid up to the moment specified in 
the box.

Once the Place order button is pressed, the instruction is sent directly to the Alpari (UK)'s 

Trading Desk. Once Alpari (UK) confirms the order, it appears in the "Trade" tab of the 

"Terminal" window.

In order to modify or delete a pending order highlight it in the "Terminal" window, then right 

click to produce the context menu:
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The context menu of the Trade tab of the Terminal window

Select Modify or delete order menu item. Press the Modify button or the Delete button 

depending on your choice in the dialog window:

How to modify or delete pending order

Execution of pending orders:

• a Buy Limit order is executed if the Ask price in the quotes flow becomes equal or 
lower than the order level; 

• a Sell Limit order is executed if the Bid price in the quotes flow becomes equal or 
higher than the order level; 
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• a Buy Stop order is executed if the Ask price in the quotes flow becomes equal or 
higher than the order level; 

• a Sell Stop order is executed if the Bid price in the quotes flow becomes equal or 
lower than the order level.

Charts
In MetaTrader 4 you can see as many real time charts as you wish, 

all on one screen, for any currency pair or CFD and for any time 

period.

The following types of charts are avaiable in MetaTrader 4:

1.Line Chart. Chart x-axis is for the different time periods (minutes, hours, days, 
months etc.), and y-axis is for the price. The point on the chart shows the close price 
for the period, i.e. the bid of the last quote for this period. All the sequential points 
are joined by lines: 

Line chart in MetaTrader 4
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It is recommended that this chart type is used only for the short time periods (up 

to 5 minutes). In order to change the chart to a line chart, press the button on 
the t ChartsC toolbar: 

Charts toolbar

or press the Alt+3 key combination or use the Charts -> Line Chart menu 
sequence. 

2.Bar Chart. The chart is created with the use of bars. Each bar has a high (top), a low 
(bottom), an opening price (left horizontal little line) and a closing price (right 
horizontal little line) for the specified period of time (for example, an hour): 

Bar chart in MetaTrader 4

It is recommended that you use this chart type for periods of 5 minutes or more. 

In order to change the chart to a bar chart press the button on the "Charts" 
toolbar 

Charts toolbar

or press the Alt+1 key combination, or use the Charts -> Bar Chart menu 
sequence. 

3.Candlesticks. These charts are created in the same way as bar charts: 
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Candlesticks chart in MetaTrader 4

Candlesticks charts were very popular in the 80-90s because of their clear 

graphics. Candlesticks were originally created only for day charts which is why 

these days they are mostly used for a daily period. This method of technical 

analysis is based on the correlation between both closing and opening prices 

within the same trading day, and the closing price of the previous session and the 

opening price of the next session.

Candlesticks have different configurations compared to bar charts. The 

rectangular part of the candlestick line is called the real body. The thin vertical 

lines above and below the body are called shadows. They show lows and highs 

within a specified period of time. Depending on the closing and opening prices 

the real body can be white (empty) or black. When the body is white, the closing 

price is higher than the opening level. When the body is black, the closing price 

is lower than the opening level.

In order to change the chart to a bar chart press the button on the "Charts" 

toolbar

Charts toolbar

or press the Alt+1 key combination, or use the Charts -> Bar Chart menu 
sequence.
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In MetaTrader 4 both the bar and candle high is the highest Bid price for the defined period, 

the low is the lowest Bid price, the closing price is the last quoted Bid, the opening price is 

the first quoted Bid.

In order to create a new chart for any instrument right click on the "Market Watch" window, 

then select the Chart window item from the context menu:

Chart context menu

By left clicking the mouse you can drag and drop any selected currency pair or CFD into any 

open chart window.

Chart period – the period displayed in one bar or candle. For example, if you create a 15 

minute bar chart, then each bar will have the price data for the relevant 15 minutes. In 

MetaTrader 4 the following time periods can be used: 1, 5, 15, 30 minutes (M1, M5, M15, 

M30 respectively), 1 hour (H1), 4 hours (H4), 1 day (D1), 1 week (W1) and 1 month (MN). 

In order to change a time period, use the "Periodicity" toolbar:

"Periodicity" toolbar
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Right click anywhere on the chart to produce the context menu to get access to the chart 

settings:

Market Watch window context menu

• Choose Periodicity and select a time period from the drop down menu or press the button 
on the "Charts" toolbar; 

• Select Refresh item if an error occurs or if there are so called "gaps" on the chart. All missing 
data will be uploaded from the server and will appear on the chart; 

• Select Grid if you wish to hide/unhide gridlines on the chart; 

• Select Volumes in order to show/hide tick volume (the number of quotes of any period time); 

• Zoom in / Zoom out will help you to modify chart measures. You can also use the / 
buttons on the "Charts" toolbar or press the "+" and "-" buttons; 

• Save as picture… will save the chart as the *.gif, or *.bmp. file; 

• Properties… (or the F8 button) enables the window where you can change chart settings, by 
selecting the "Color" tab you can change the color of any element on the chart: 
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Color tab of Chart Properties window

Other settings can be changed in the Common tab:

Common tab of Chart Properties window

Please note the following options:
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• Offline chart - the chart is not being updated by new quotes. Once you open the chart offline 
(File -> Open offline) this option becomes automatic; 

• Chart shift - allows to shift the chart from the right edge of the window. You can also press 
the button on the "Charts" toolbar or use the Charts -> Chart shift menu sequence; 

• Chart autoscroll - disables/enables chart autoscroll to the left once a new quote is received. 
You can also press the button on the "Charts" toolbar or use the Charts -> Autoscroll menu 
sequence.

www.meta-trader.co.uk  we programm your Strategie


